sele technical - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 10-11-08 Thread Starter
Status: -
AO Member
thespanishadam's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Kent
Posts: 44

Member car:

147 selespeed

sele technical

Being a 147 sele owner, wanted to see if there is anything to do to look after the box after reading soo many threads about problems with the phantom actuator. Any tips? Does driving it on city mode make any difference?
thespanishadam is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: sele technical

Driving in "City" mode makes no difference, apart from winding you up and being bad in town/city.

Keep it in manual mode in town.
David C is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
Re: sele technical

keep an eye on the mileage, the clutch release bearing will go at about 120k (kilometres) as did mine ! and when you get stuck in gear you are in deep sh*t.... because the car cannot be pushed or pulled.... the bearing starts with a little whine which gets worse, I was stupid enough to keep driving it too long.
rarebear is offline  
Status: Summers on the way
AO Member
Join Date: Nov 2008
Location: New Zealand
County: Auckland
Posts: 35
Re: sele technical

Hi why is city mode problamatic around town?
A Romeo is offline  
Status: wheeeeeeee!
AO Silver Member
Gaag's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: North Lanarkshire
Posts: 1,450
Images: 13
Re: sele technical

I don't think it is problematic... it's just that in auto it holds on to the gears for too long before changing.

It's more economical to drive in 'manual' mode.

I tend to only use city mode to periodically check it's still working these days!
Gaag is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

sele , technical

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome