reverse lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-11-08 Thread Starter
Status: -
AO Member
leonwolves's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Cheshire
Posts: 275

Member car:

147 2.0 ts 2001

Help reverse lights

hi guys n gals not been on for a while alfas been off the road for over a year but got it motd yesterday and passed with only minor probs.anyway my reverse lights hav never worked and now its gettin dark earlier could do with em i noticed the connecter fo the gear box had been unplugged afta pluggin it in the reverse lights worked but blew the fuse for the elec windows i replaced fuse but same again, p.s when i plug connecter in gearbox all is ok until i select reverse then fuse blows but reverse lights still ok. any help would be much appreciated thanx
leonwolves is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

lights , reverse

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome