Frustated with sensors!!!!!!!!!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: Durham
Posts: 7
Help Frustated with sensors!!!!!!!!!!!!

Hi. Just bought a 2001 2.0 156 sportwagon manual e bay special all the way to Norfolk to collect it. Car was great but as the traffic in the area was rubbish i never wellied it. Reaching the A1 i did so to find out it would only rev to about 3500. I unplugged the maf which enabled it to rev, indicating faulty MAF. I fit a new one revs ok now but then started to cough occasionally and engine light came on. I plugged the car in fault codes indicated o2 sensor cambelt end and maf sensor again. i swapped the plugs over i.e. left/right o2 sensors, and plugged in again after light came on. This time 2 codes maf again and gearbox side o2 sensor. Great obviously 1 faulty sensor. I fitted a new 1 and reset light again. Drove for about 6 mile and it coughed a big one and light came on again. Plugged in and guess what? maf sensor. The car revs ok, so to check i refitted original maf and it wouldnt rev. Put new one back on reset light engine cough again fault code p100 maf.
The only other symptoms are every now again tickover goes to pot for a few seconds and i dont think its as quick as it should be. But my last 3 cars were volvo t5 scooby and octavia vrs so it could be me!
Any ideas/advice would be appreciated.
cheers Steve
celicatintin is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

frustated , sensors

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome