help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 04-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: West Midlands
Posts: 3

Member car:

not my car 156


hi im new to this site and the 156 but can someone please help i had to take radio out of the car and when i put the radio back in it asked for the code but could not find it then when i did find it the radio does not ask for the code and cant get it back on can some one help me with this please also when we start the car it sounds like a disel its a 2000 156 ts thank ash
mazda_mx6 is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
Re: help

When you start the car it sounds like a diesel - this means your variator needs replacing.

The part costs around £100 but involves the removal of the cambelt to fit it. Where are you based?

Can't hlp with the Alfa radio, in both my 156s they were a pile of sh*te so went in the bin.
Pud237 is offline  
Status: Hopeful but confused
AO Member
JayCee's Avatar
Join Date: Oct 2008
Location: Ireland
County: Laois
Posts: 127

Member car:

156 2.0 JTS

Re: help

If you do a search for "radio code " you may get some help here ..

The previous poster is correct about the diesel noise , unless yours happens to be a diesel.

If your car has an unknown service histery , plan to get balance belts , timing belts and water pump done at the same time as the variator.

After that you will have most of the causes of major grief covered ..
after that ... Oil , oil filter , air filter and your sorted.

What milage is on it and what engine ...any history ..

Ohh and btw ....Welcome
JayCee is offline  
(Post Link) post #4 of 5 Old 04-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: West Midlands
Posts: 3

Member car:

not my car 156

Re: help

yer thank its got about 100000 on the clock but about 3000 of them my better half has done on m way its got full service with the next one due now and is 2lt thats really slow when we put up to the mazda she owns but apart from that its a good car
mazda_mx6 is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: help

Cam belt should be replaced every 3 years or 36000 miles, so it might be ready for a change. Otherwise you might find an oil change will quieten the variator down for a while, but the only real way to cure it is to replace it.

You could try taking it out again ... otherwise you need to leave it switched on for a bout an hour to reset ... which probably means driving it as it will switch off after 20 mins.
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome