166 Bulbs go 'pop' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
166 Bulbs go 'pop'

Just finished replacing front cigarette lighter bulb(thanks calzone)then checking rest of lights noticed left front dip light (12v 55W)was not working. Found bad connector in plug. Spade connector had opened up. Fixed and replaced.Then 30 mins later same side, front side light not working(12v 6W). Found it had blown. Replaced OK.

Two hours later right front, side light not working.Bulb blown, replaced ok. Then took car for drive got dark then noticed front right dip not working.Found bulb blown (12v 55W). Replaced OK.

And then noticed rear cigatte lighter 'light not working.

So it would seem that my car 3 years old is going through its bulb life span all at once?
Sponsored Links
Status: -
AO Gold Member
Banflu's Avatar
Join Date: Aug 2002
Location: Malta
Posts: 6,476
i always thought alfas were very consistent
Banflu is offline  
Status: Always hopeful yet discontent.
Club Member
Membro Premio
Ant's Avatar
Club Member Number: 92
Join Date: Jun 2002
Location: Somewhere far beyond...
Posts: 38,299

Member car:

2014 Honda CR-V

Consistently inconsistent...
Ant is offline  
Status: - Update
Posts: n/a
Think I remember the technician at my dealer told me once that there is smoe sort of known problem with the front lights on the 166, have you checked with your dealer?
Status: - Update
Posts: n/a
No I have not. If you talk to my local alfa dealers they nearly always say that they have never heard of the fault you have. Perhaps you could find out from your dealer more details? He sounds helpful.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

166 , bulbs , pop

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome