Help - New 147 owner!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-10-08 Thread Starter
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: Gloucestershire
Posts: 3
Help - New 147 owner!!!

Hello I bought a 147 just under a week ago! The car is stunning and i love it, but i have this issue with the keys!

The main key worked fine intailly unlocking/locking the car etc. but the previous owner did tell me the battery was on the way out. Anyway it stopped working, so i changed the battery and it still does not work!!! I'm getting a single flash on the LED and thats it.

I did unlock the car manually and set the alsrm off but turned it off by putting the key in the ignition to MAR position. Is this a return to the dealer fix?

Can anyone help this inexperienced Alfa owner please???

Thanks Noddy
noddy182 is offline  
Sponsored Links
Status: -
AO Member
mattydan's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Aberdeenshire
Posts: 42
Re: Help - New 147 owner!!!


I'm new to Alfas too - had my 147 for about a month now.

I had exactly the same issue and I checked all the posts I could find on this site - everyone says it's a dealer only fix.

I got 2 new keys (as the old one was falling apart) supplied & coded by the dealer...For 250! Work a treat now, though.

If your key(s) are still in OK condition, you should be able to just re-code them, and should only charge you labour, so you should be able to get them done for less than 50. If you need new keys, then they're 100 each.

Hope this is useful.
mattydan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome