In Need of Help!! clutch gone? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-10-08 Thread Starter
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: Merseyside
Posts: 2

Member car:

147 1.6 t spark

In Need of Help!! clutch gone?

Well i got my car last week andloved it until now. the clutch has sunk? i need to know wehter its serious or just something come loose. when i press the pedal its like the clutch has gone, i need help asap !!!
Smithy123 is offline  
Sponsored Links
Status: Changed clutch,what's next....
AO Member
Join Date: Jun 2007
Location: South Coast
Posts: 337
Re: In Need of Help!! clutch gone?

I could be the clutch hydraulics gone (or just needs bleeding). Can you engage any gear.
Is the clutch slipping?
jdg is offline  
Status: - Update
Posts: n/a
Re: In Need of Help!! clutch gone?

Try looking at this thread.

Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: In Need of Help!! clutch gone?

Slave cylinder seals clapped most likely, or could possibly be the master cylinder. More likely the hydrostatic slave.:
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome