first 4 months of 147 ownership - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
first 4 months of 147 ownership

after 4000 miles of mainly happy motoring here are the points i have realised or things that have happened

1) Motor control system failure after 2000 miles, traced back to the knock sensor

2) Rear light fog failure once, never seen again (fog working)

Roof strips replaced either side due to them sinking a bit

Car was bought from reg vardy who have provided first class service every time (sorry if i cant mention dealers name)

1/2 litre of oil required at 3500 miles

I still cant understand the climate control system

Natural leather is an absoloute pig to keep clean

Engine is getting sweeter every time i drive

i will be sorry to see it go as my fiancee is getting it when i order my 147 gta
Sponsored Links
Status: Lapping Mondello
AO Silver Member
Toad's Avatar
Join Date: Apr 2001
Location: Ireland
County: -
Posts: 1,831

Member car:

75 LE

Rate your garage here.

GTA .. you lucky sod, you'll have to take pics of his'n'hers 147's when it arrives
Toad is offline  
Status: -
AO Silver Member
G-147's Avatar
Join Date: Dec 2001
Location: Derbyshire; UK
Posts: 3,349
i'm throwing my life away for a GTA wink (hopefully )
G-147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , months , ownership

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome