12000 Service - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 23-09-02 Thread Starter
Status: -
AO Member
Join Date: Jun 2002
Location: London
Posts: 40
12000 Service

hey guys
I bought my 147 2nd hand 1year at 9000miles. Just serviced before I got it, now it is very near 12000miles. I keep have this warning to have it service at 12000!
Is it really nessary to service my car again as it has been done 2 months ago? What do I have to do to reset the service warning?

Pls help!

Wonton is offline  
Sponsored Links
Status: -
Club Member
Membro Premio
Club Member Number: 1561
Join Date: Dec 2001
Location: Netherlands
County: -
Posts: 12,865
Images: 305

Member car:

busso powered

Just go to an Alfa dealership and let them set the interval to 21.000 miles and 10 months from now. The probably forgot to reset it when it had its service.

selespeed is offline  
Nicola Romeo
Status: - Update
Posts: n/a
I would seriously get this checked out by the dealer, yesterday when the AA and I towed my selespeed back there was this guy before me in the reception who went 2000 miles over his 12,000 mile serivce and he was told flat out YOU HAVE LOST YOUR WARRANTY they allow 500 miles over and that's it.
This happened to my other half a few years ago on a 406 and she only went 36 miles over so we agreed NEVER to buy a car from them again, 2000 over yeah, 36 is a bit naughty.

Check it out as soon as possible they love to take your warranty away.
My car was serviced (156 1999 selespeed) when I bought it 15000 miles but I still brought it in for its 24000 service at 23000 just to be on the safe side, the milage was the first thing they check, then they don't say anything, service your car, give you the big bill, and tell you just when you're leaving 'oh by the way you've lost your warranty! you went over the milage sir and there is nothing you can do at all about it.
(Post Link) post #4 of 7 Old 24-09-02 Thread Starter
Status: -
AO Member
Join Date: Jun 2002
Location: London
Posts: 40
Just spoke to Alfa customer service. The service is either 1 year or 12k whichever come first.

Done 1st year service on May 2002 at 8500miles. The next one would be May 2003 or 20500miles (8500+12000).

I suppose the other guy lost his warranty cos he had not done his annual or 12000 on time!!
Wonton is offline  
Nicola Romeo
Status: - Update
Posts: n/a
I am starting to feel the need for asking for things in writing, my experiences so far are becoming tiresome to say the least

The car they have given me for now is horrible,a ****y little punto YUK! I fookin hate it even though it's the slecta model horrible road noise, ride too high, no power at all six stupid gears! pointless! and vauge steering, better than nothing I suppose not much though.
Status: -
AO Gold Member
Banflu's Avatar
Join Date: Aug 2002
Location: Malta
Posts: 6,476
well i have never serviced it at the dealers after 16500km/1.5 years, and probably never will. i already changed the oil+filter 3 times though. i dont like the idea that the same oil stays in the sump for such a long mileage.

i think a gallon of oil is quite worth the trouble you could have with lack of lubrication, wear and tear, etc..

i dont know what i'm gonna do when it starts beeping for the service though..

probably i'll have to go to the dealer to reset it or something..

Banflu is offline  
Status: -
AO Silver Member
jomor's Avatar
Join Date: Apr 2002
Location: Hellas
Posts: 5,237

Member car:

147 1.6lt

Maybe its irrelevant but i want to express my anger. A neighbour just did his first service at ...80.000km !!!!!!!
Till now he was changing the oil by himself, and nothing else. Not a single problem till now, not a single creak. He has a four years old Hyundai Accent god damn it!!!

Shιt !!!

jomor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome