GT Selespeed - diagnostics problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-10-08 Thread Starter
Status: Departed for the blue oval :(
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: West Sussex
Posts: 161
GT Selespeed - diagnostics problem

Hello all

I am (hopefully) getting a loverly blue metallic 2 litre GT Selespeed this weekend. I say hopefully because it's in the workshop at the moment having it's computer replaced.

Apparently there was a problem with the fuel/air control to the engine which was being controlled by part of the on-board computer. This meant that the car did start sometimes but kept cutting out.

It obviously needed a part to be replaced. Unfortunately Alfa Italy sent the wrong part - I hear that the Selespeed requires a different computer or something - but should be getting sorted now.

Fortunately it's my old man's car so he is paying for all the repairs and Alfa may well contribute too due to their **** up over parts.

Just wondering if anyone else has had this type of problem with their GT and whether it is recurring.
I will be well upset if I have to fork out hundreds for it if/when it goes wrong again!
eastendmyfreind is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: GT Selespeed - diagnostics problem

I had an ECU fault and the ECU had to be replaced. She was running very very rich all the time. Don't think it's common though. I don't know of anyone else having to have their ECU replaced...............

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

diagnostics , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome