147 Selespeed Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-10-08 Thread Starter
Status: -
Join Date: Sep 2008
Location: United Kingdom
County: Greater Manchester
Posts: 1

Member car:


147 Selespeed Problem

Having read through a lot of posts RE: selespeed I thought I'd ask a bit of advice.
I started the car this morning & set off.....I turned the corner and it fell out of gear. I stopped and it would not select any gear....all the bells & whistles flashing 'selespeed system failure'. I turned off the ignition and started again, it slected 1st, 2nd, and then all the bells and whistles again.
It will not select Reverse, 3rd, 4th, 5th and when in 1st sat still and I change to neautral the engine almost stalls??!!?! (Not heard of that on any posts)
I have checked the battery and changed it to be safe - no joy.
Oil seems ok to. It has given no idication of a failure prior to this, and simply will not get to a garage - centre of Manchester, so nearest service centre is 15 miles away in 2nd gear

Any advice/thoughts greatly appreciated...
power007 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: 147 Selespeed Problem

Hi and welcome to AO I hope you get your Alfa sorted quickly.

moved to 147 tech lounge
classicgal93 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome