Fix 147 VDC issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
147dude
Status: - Update
Guest
 
Posts: n/a
Fix 147 VDC issues

Hi guys,

got my car back after 10 days of thorough repairs and testing by the workshop and importer. they've replaced the ABS pump unit on the car. The importer says it's not official, but there has been a software upgrade on the ABS unit that should help. He's tested it during the weekend after I showed him the fault two weeks ago, and says it's ok. I am testing it myself this weekend, and will get back when I know for sure that it's ok. Hope this can help someone who has the same fault, after my six months and 18000km's of driving a not-working-perfectly 147... wink very happy now!
 
Sponsored Links
Advertisement
 
Status: -
Club Member
Membro Premio
 
Club Member Number: 1561
Join Date: Dec 2001
Location: Netherlands
County: -
Posts: 12,865
Images: 305

Member car:

busso powered

I sincerely hope your baby is cured.

Selespeed
selespeed is offline  
Status: -
AO Gold Member
 
Banflu's Avatar
 
Join Date: Aug 2002
Location: Malta
Posts: 6,476
what was wrong with it 147dude?
a software upgrade on the ABS sounds great, i am not impressed with the abs at all and it was already changed when about 1-2 months old because my dad and I crashed into another car...it didn't wanna stop for some reason or other so BANG into a pajero :/
after some abs/asr/ebd errors they changed the abs unit and said it was now ok. no errors but still braking is not so good...
hope yours is ok now!
Banflu is offline  
147dude
Status: - Update
Guest
 
Posts: n/a
The fault I had was the VDC cutting in way too early, especially in medium fast turns, 60-80 kmh speed, and in fifth gear, barely touching the pedal. You notice this, because it starts braking on individual wheels... After some "testing" this morning I can say 98% surely the fault is completely gone... Wohooo!
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
147 , fix , issues , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome