Airbag warning lght ON always - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Airbag warning lght ON always

Hello ppl,
I drive a 02 alfa 147 2.0 t-spark. Bought it in april and since then everything has been superb apart from an airbag system failure light that has appeared twice on my dash. first time it happend I took it to the dealer and they jsut reset the computer and things have been fine until 3 weeks ago. It has reappeared. The red light satys on after ignition even after the trip computer says OK. Funniest thing is that the alarm appeared at the same place and time and whether!!! Showcase Nottingham HOt day 30 plus on teh trip computer and a engine oil pressure low alarm just before parking and watching a film. When you return expect a airbag light permantly on when the car is turned on! CAn't be fixed unless you go to the dealer. So as a word of warning, don't go to watch any films at nottingham showcase.

If anyone has had similar problems can you please reply. Thx.
Sponsored Links
Status: - Update
Posts: n/a
I've had the same identical problem with my 147, obviously not while watching a film. My was being generated by a loose connection with one of the sensors in the drivers seat. The prob is, that even if the connection fails for a few secs the warning light will go on and stay on until it's reset by the dealer, so I guess it's pretty hard to find which one of the sensors is causing the problem, since it's an on and off thing.

Status: -
AO Member
Join Date: Jan 2002
Location: South Africa
Posts: 41
I had same thing with my 147. After they reset it numerous times I was ****ed off with having to take it back, so they eventually changed the airbag for a new one under warrenty and that sorted it out for good. Incidentaly they forgot to note which airbag was causing the problem from the error report and ended up guessing and having to actually change 2 airbags - their loss!
jmorgan is offline  
Nicola Romeo
Status: - Update
Posts: n/a
I have had the same hassle three times on the passenger side airbag, but they seem very reluctant indeed to change anything it seems fine now anyway...fingers crossed.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

airbag , lght , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome