147 lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-09-08 Thread Starter
Status: -
Join Date: Aug 2008
Posts: 2

Member car:


Help 147 lights

I keep getting light failure signals and sometimes number plate light failure. Also my left side rear light stays on all the time even when key is out of the ignition.

Can anyone help me out on what is wrong and if it'l be costly?
jalfa romeo is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: 147 lights

Usually a fault in the bulb failure detection circuit.
On a 156 it would mean a new rev-counter.

Not sure if the same applies to a 147.
David C is offline  
Status: Back in the fold
AO Member
Join Date: Apr 2008
Location: United Kingdom
County: Essex
Posts: 199
Images: 2
Re: 147 lights

Similar to me. My 147 rear light was staying on all the time, even with key out.

Took it to be tested, as only 6 volts where showing up at the back light unit. They tested circuit back to body computer and all cabling was fine. Was told that i would need a new body computer - £400 (£270 + Labour)....
RobinBrentwood is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome