Buzzing noise from the climate control box in GT? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 19-09-08 Thread Starter
Status: -
Join Date: Jul 2008
Posts: 7

Member car:


Help Buzzing noise from the climate control box in GT?

Perhaps, I'm just being paranoid, but recently I've connected the Dension ICE>Link iPod connection in my GT and I've noticed the strange buzzing noize (like something is trying to turn on but failing) from the climate control block.

I'm not quite sure whether I heard it before (I think not), but now it appears every time I turn the engine key to MAR position (or turn on the ignition). The noise persists even if I turn the climate control totally off. However, the climate control itself works okay and I couldn't find any other signs of the problem except this annoying noise.

I disassembled the console and I'm 100% sure that the noise comes from the climate controls. I didn't disconnect the block, though; but I'm sure that all wires are plugged tightly to the climate control box.

Should it be like this (I have GT for about a month - so, maybe, I didn't notice it before)? Or should the GT be completely silent (with climate control turned off) when the key is in the MAR position and the engine is not started? Any ideas what could be wrong with this control box (thermo sensor?)
Rdyandalir is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: Buzzing noise from the climate control box in GT?

If the GT is the same as the 156, then there is a small fan which is used to check the internal temperature, and this is probably what you can here. On the 156 there's a small round grill on the left of the control panel .. the fan is behind that.
gazza82 is offline  
Status: -
AO Member
Join Date: Aug 2009
Location: United Kingdom
County: East Sussex
Posts: 60

Member car:

147 jtdm

I am just like you, I have a 147 and just noticed the noise. It has probably always been there, but when you become aware of it, it is quite loud!! I hope it is normal. Would be interesting to know if other peoples climate control panels buzz!
Lee Ryall is offline  
Status: -
AO Member
Alfateer's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Kent
Posts: 33
I have a buzzing noise coming from my 156 climate control unit, almost certain it wasn't there before!
Alfateer is offline  
Status: -
Join Date: Oct 2009
Location: United Kingdom
County: Antrim
Posts: 7

Member car:

alfa 147 ti

This is definitely not normal the problem has just come to mr today, is there any1 put there that knows what needs to be done to pit it rite?

147 ti is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

box , buzzing , climate , control , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome