147 CD/Audio system fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
147 CD/Audio system fault

I'm going to get the garage to take a look at this next week, but wondered if anybody else had the same problem....

Occasionally, the audio system (standard - not the BOSE version), will detect there's a CD Changer (which there isn't) and then displays ERROR...I can cycle through the radio channels, but where the CD should be is the CD CHANGER or ERROR message. If I switch the audio system off and back on again, it all starts working correctly. This even happens if (for example), I'm playing a CD, stop the car, and then when I restart it'll think there's a CD changer.

It doesn't happen all the time - anybody else experienced the same?

Sponsored Links
Status: - Update
Posts: n/a
hi steve

I had exactly this problem with mine a week ago. Switching the radio on and off didn't seem to help, but it appeared that switching the engine off and back on again did ...

Mysterious one, but it hasn't happened since..
Status: ready4vacations
AO Platinum Member
Join Date: Jul 2002
Location: Portugal
County: Porto
Posts: 31,304

Member car:

Alfa 159 QV

You might see de newsgroup alt.autos.alfa-romeo
Theres was two Alfa owners with the problem you bouth have.
They didn't get an answer.The remedy to one was to simply turn the radio off (not the engine).

Mine works fine.

THROTTLEMAN is offline  
Status: - Update
Posts: n/a
I've had the same problem too Steve, sometimes it finds a changer, sometimes it just goes on for a while, displays cd error, and then acts as if there's no cd in the player, even though there is. I then have to turn it off and back on (the player) to play or even to eject the cd... wink
Status: -
AO Member
Rico JFDD's Avatar
Join Date: May 2002
Location: Greece [+=] ELLADARA
Posts: 638
I often have the same problem; if it isn't displaying ERROR or CD CHANGER then the CD is skipping all over the place...

Personally, I would let my usual dealership touch the car's internal organs again.... they just screw things up more...
Rico JFDD is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , cd or audio , fault , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome