I think my MAF is dead! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-09-08 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 41

Member car:

156 selespeed

I think my MAF is dead!

The symptoms are as follows;

When cold the car coughs and splutters with anything greater than about one quarter throttle, if you give it a lot of gas, it will fire through the exhaust (not good!)

After about 5 minutes, it clears and runs normally unless I use more than 3/4 throttle, when it sounds like its miss-firing and loses power.

I disconnected the MAF and it still misbehaved when cold, but ran ok when warm, apart from a very ebrupt throttle response at low speed.

Am I on the right track, or barking up the wrong tree?
pistonhead72 is offline  
Sponsored Links
Status: enjoying ma julie
AO Silver Member
belfast bob's Avatar
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
Re: I think my MAF is dead!

most likely is the MAF, try swapping with someone with a good one to test
belfast bob is offline  
Status: No more GTA
AO Silver Member
pcbuild2k's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Cheshire
Posts: 1,496
Images: 25

Member car:

156 JTS

Re: I think my MAF is dead!

best test is to run with the maf disconnected to diagnose a faulty maf, if it runs properly disconnected then it needs replacing
pcbuild2k is offline  
Status: - Update
Posts: n/a
Re: I think my MAF is dead!

I have one in my 2001 1.8 TS Sportwagon I'm breaking that works perfectly. I believe that all Twinspark MAF's are the same, whether in the 1.8 or 2.0 guise?

If that's the case then you can have mine for £15 + postage if you like.

Of course find out if that is the fault first.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

dead , maf

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome