Flashing Odometer - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-09-08 Thread Starter
Status: Now Alfaless
AO Member
Killer2008's Avatar
Join Date: Apr 2008
Location: Dewsbury
Posts: 305

Member car:

Honda S2000

Flashing Odometer

Just driving through Leeds today, and I've noticed my odometer has started flashing this afternoon. Whats that about then ?
Killer2008 is offline  
Sponsored Links
Status: Looking forward to a drive
AO Member
Join Date: Apr 2008
Location: United Kingdom
County: Cheshire
Posts: 216
Re: Flashing Odometer

I had this too after my car came back from some having some damage repairs . It means that something somewhere is not working as it should be (typically vague I know). In my case it was flashing because i needed a "proxy realignment" which is some kind of refresh of the body computer I think. The reason mine was flashing was that when the car was repaired the boot locking mechanism and the rear parking sensors were replaced and although they worked fine, they were causing some kind of error because the body computer didn't recognise them so it needed this refresh. I got it into a dealer and they did the necessary, took them 30 minutes and it would have cost 45 but was covered on the warranty in my case. I did try and get an independent guy in first to do a diag but he didn't have the necessary equipment/software so I had to go to a dealer in the end. Seems to be a common thing though as their are a few threads on here about it. I did ignore mine for about 3 weeks then i started blinking in time with it and decided to get it sorted Good luck!
GTMAT is offline  
Status: - Update
Posts: n/a
Re: Flashing Odometer

As GTMAT says, it indicates a failure during start-up checks
on the car's CANBus. Try a thread search as there have
beeen many previous posts about "flashing odometer"
and "proxy alignment"

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

flashing , odometer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome