1.6 ltr - enough midrange - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
1.6 ltr - enough midrange

Thinking of buying a 1.6ltr 3dr Lusso. Seen lots of comments about 1.6ltr's lack of grunt. Given I've grown out of the boyracer stuff I'm not too bothered about stunning 0 to 60's. However does the 1.6ltr have enough torque for reasonable everyday fun driving??
Sponsored Links
Status: -
AO Silver Member
jomor's Avatar
Join Date: Apr 2002
Location: Hellas
Posts: 5,237

Member car:

147 1.6lt


But since you have a Kawasaki ZX6R i recommend a test drive (take a taxi to the Alfa dealer not your bike wink
jomor is offline  
Status: - Update
Posts: n/a
Even the 2.0 lacks torque - I believe Alfa engines tend to be top end units - think GSXR and you'll get the picture.

What about a Diesel?
Status: -
AO Silver Member
G-147's Avatar
Join Date: Dec 2001
Location: Derbyshire; UK
Posts: 3,349
Its got enough me thinks...... after all, all you need is to drop down a gear!!!!! Go on......... get one... you know you want to be special wink
G-147 is offline  
Status: No more guiletta... Auctioned off
Founder of AO
alfaowner's Avatar
Join Date: Apr 2001
Location: United Kingdom
County: Essex
Posts: 8,044
Images: 83

Member car:

Maserati GTS

My personal opinion was its a bit too slow if left standard, but boy they are great engines to play around with.

Just my 2 pennies.
alfaowner is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ltr , midrange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome