Problem with V6 Speedometer - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
rehan samee
Status: - Update
Posts: n/a
Problem with V6 Speedometer


The speedometer on my 1998 MY 156 V6 has started misbehaving. The needle swings all over the place even when the car is moving at a constant speed. Sometimes when the car is stationary (but idling), the speedometer needle shows the car to be travelling at speed (20 to 60 km-h).

The dealer in Dubai (there is only one) feels that the clock spring inside the speedo has failed and lost its damping effect. However, that still doesn't explain its behaviour when the car is completely stationary, with the engine on idle.

Any experience with, and solution for, this problem would be greatly appreciated before I fork out c. GBP 150 for a new speedo.

Thanks & regards,

Sponsored Links
Status: cornea come l'inferno
AO Silver Member
Hoygaard's Avatar
Join Date: Apr 2002
Location: Denmark
County: Kobenhavn
Posts: 4,156

Member car:

156 GTA SW

I suggest U have the speedo sensor checked with a scope. If it doesnt show any fluctuating signals, then consider yourself 150 poorer.

All the best

Hoygaard is offline  
rehan samee
Status: - Update
Posts: n/a
This is an update on the speedo problem I had reported earlier.

The dealer in Dubai "cleaned" the ABS sensor (apparently, the speedo gets its input signals from the ABS sensor) and the wire / connector contacts behind the speedo unit itself .... and everything seems fine!!

If the speedo in your 156 starts acting up as described, this may be worth a try before putting down GBP 150 for a new speedo unit.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

problem , speedometer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome