Clutch Pedal Catching - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-08-08 Thread Starter
Status: -
AO Member
Zlov's Avatar
Join Date: May 2008
Location: Chipping Sodbury
Posts: 101

Member car:

147 JTDm 16v Q2

Clutch Pedal Catching

The clutch pedal on my 147 seems to be catching on something when you let the pedal up. It happens in two places, not enough to stop the pdal returning, but annoying never the less.

I've had a look in the foot well and there is nothing obvious down there, in fact the factory put so much white grease on the return spring some has fallen off in a blob on the carpert.

Is this clutch operated by a cable, and if so could this be the problem?
Zlov is offline  
Sponsored Links
Status: Changed clutch,what's next....
AO Member
Join Date: Jun 2007
Location: South Coast
Posts: 337
Re: Clutch Pedal Catching

I have this probelm now and again. Two things cause this for me. The hydraulic system need bleeding (clutch is stiff), also gets caught on the floor mat. Do a search on clutch bleeding.
I pump the clutch a few times which seems to ease it, haven't got round to bleeding it yet.
Worst case is your clutch release system is on it's way out. Again do a search on this.
What is your brake fluid level like?
jdg is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

catching , clutch , pedal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome