only rev's to 4500 ?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-08-08 Thread Starter
Status: -
edinburgh's Avatar
Join Date: Jul 2008
Location: gorebridge,nr edinburgh
Posts: 8

Member car:

156 black

only rev's to 4500 ??

hi guys my 2001 alfa 156 1800cc veloce recently got its crank angle sensor by great garage, engine fault light on and only rev's to 4500 revs ?? is this a "safety mode" what should i do ?? thanks
edinburgh is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Re: only rev's to 4500 ??

Quite possibly MAF (air-flow sensor). Seems to be the culprit for most revving faults.

I've got a copy (legal, I hasten to add) of AlfaDiag that I could have a look at it with if you like...I'm in Kinross, so not a million miles from you!


iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

4500 , rev

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome