Electric Windows on 147's - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-08-08 Thread Starter
Status: -
AO Member
AlfaJohn's Avatar
Join Date: Jul 2008
Location: Bonnie Scotland
Posts: 104

Member car:

147 2.0 TS Lusso

Electric Windows on 147's

Seen quite a few folk on here having problems with rear electric windows not working on their 147's and seeing as it took me 2 months to figure out that my broken window wiper motor was a common problem I thought I would start a thread.

So how many of you guys have had this problem? You guys are out there as I have seen the posts! And what did you do to sort it?

As I said one of the rear windows work fine but the other doesn't even make a noise. Any help?
AlfaJohn is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2008
Location: United Kingdom
County: Bristol
Posts: 15
Re: Electric Windows on 147's

Got the same problem with mine....anyone anyone..bueller!

No noise when button pressed?
gw101 is offline  
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: South Yorkshire
Posts: 123
Re: Electric Windows on 147's

check the wiring in the rubber thing in the doors, not sure of the proper name but they are nutoriously bad for snapping. nearly as bad as on 306's. the wires probably all run through the switch panel on the drivers side too so if one of the switches fails, that window won't open until it is replaced. hope this may help
phoebus is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , electric , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome