156 v6 flat spot under 5000rpm help needed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-08-08 Thread Starter
Status: -
petethebish's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Glasgow
Posts: 1
156 v6 flat spot under 5000rpm help needed

my 1998 156 v6 has all of a sudden developed a real lack of power and hesitation under 5000rpm. once she hits 5000rpm she starts to pull as she used to. i thought it might have been the spark plugs so i swapped them for a nice new set of ngk platinum plugs off of ebay. the change of plugs has helped a little but the flatness is still there and i am now thinking it could be the maf is there any way of testing the maf so i know for sure as after looking at other posts i think it could also be failing coil pack. i'm also getting shockingly poor mpg
petethebish is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 5000rpm , flat , needed , spot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome