New 147 Selespeed Owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Jaco C
Status: - Update
Posts: n/a
New 147 Selespeed Owner

Hi I'm new to this forum. Have been visiting as a guest regularly the past few weeks. Received my 147 2.0 Selespeed about a month ago. When not here I'm out driving. It's really a masterwork of a car. Had no problems yet with it (unlike other reports that I read on here). Only thing is the Km reading display that flashes now and then, but that the dealer told me happens when you start driving before the Self Check is finished ( dont know if I must believe that). But it seems to help. The other thing is the changing over between 2nd and 3rd in City mode seems to take forever ( sounds like a granny driving). I do like it when racing, but not under normal circumstances.
Haven't taken the car with leather yet, as the leather fitting they do here in Cape Town after import. The car is black is black and couldn't decide on colour at that moment, so will do it in this year still. Does anyone maybe have black and red leather combined or with red stitchings, or even plain red( dont know if I'll like it though). I'm looking for pictures to help me decide? Can anyone help?

Sponsored Links
Status: - Update
Posts: n/a
Howdy Jaco!
Red leather noooooooo, tan leather yes! But then I am biased.

Status: -
AO Silver Member
G-147's Avatar
Join Date: Dec 2001
Location: Derbyshire; UK
Posts: 3,349
I'm looking for pictures to help me decide? Can anyone help?

Under gallery, choose interior!!
G-147 is offline  
Status: - Update
Posts: n/a
I've found you can safely start the vehicle before the 'check' has completed - with no prob's.

The flashing km's only seems to happen if you start up the very shortly after check completes.

So either start it up straight away - or if u must wait for the check leave it about 2 seonds after that before starting.

You're also more likely to get the erroneous light faults etc

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , owner , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome