first track day in the 147 - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hi Dave, I understand you have also lowered your cars and you say VDC is perfect!, In another post in here they say that VDC is causing errors and problems when lowering your car. Have you done something in particular with the VDC when lowered your car, or did you leave it as it was? Tx!

NIce pics!!!!

Sponsored Links
Status: -
AO Gold Member
Banflu's Avatar
Join Date: Aug 2002
Location: Malta
Posts: 6,476
i thought the plastic headlamp cover was safe in an accident and doesnt break like glass..
Banflu is offline  
Status: - Update
Posts: n/a
The VDC has definately stopped working.It was fine on the first outing on Pirellis and when i put Toyos on it stopped.The car is better on these tyres without the VDC.The car will move on all 4 wheels as you balance on the throttle through the corner,whereas the VDC tried to work to early for me.On the road the VDC was fine,but the car seems better now.Could be the tyres though.
Status: - Update
Posts: n/a
Tx Dave, in that case and based on the facts that a lot of others have lowered theirs I will definetely go trough with it! Enjoy your next track session Ciao!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , day , track

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome