Odd electronic events - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 13-08-08 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 5
Help Odd electronic events

Any help appreciated. My 02 plate 156 sportwagon has a selection of problems.
1. The external temperature gauge every now and then says it is -18 outside which send the heating into full blast and steams up the car!
2. The lights, rear brake and front side lights so far, stop working the warning comes on on the dash then after a few restarts the lights work again.
3. The ABS failure warning came up then went away again.
4. The windscreen wipers decided to stop where they were when I flicked them off the other day then worked again.
5. Driving the other night the engine warning light came on and the headlights went out for a split second then back to normal.
The garage (alfa dealer) said they thought the temperature gauge fault was something in the dash and they could change it for 500!
Could all the above be connected?
I love my car but should I be expecting catastrophic failure?!
josnet is offline  
Sponsored Links
Status: -
Awaiting Email Conf
Chill's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Lake District
Posts: 1,773
Images: 26
Re: Odd electronic events

Could be damp - try spraying some WD40 on any connectors you come across. Also, check the condition of your battery.
Chill is offline  
(Post Link) post #3 of 4 Old 18-08-08 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 5
Re: Odd electronic events

Thanks Chill, I will look out for connectors and spray them. Would the battery have been checked at service as its just had one. I guess I could look at the list of things they did. Thanks for your tip though.
josnet is offline  
Status: -
AO Platinum Member
156Chris's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Surrey
Posts: 12,877
Images: 12
Re: Odd electronic events

Or it could just be that your battery needs changing ... go and get it checked ...
156Chris is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electronic , events , odd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome