please help major overheat problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Warning please help major overheat problems

ok this is for 2.5l V6 156

I was in Alton Towers on saturday when I got there car was unusually warm let it cool for the day when I come back checked oil and water and both were fine within two mins of leaving Alton Towers my car overheated with both fans coming on.

Long and short of it I got towed home, RAC think head gasket but I am not so sure. What do you think?

1. I checked my oil both at the cap and the dipstick no emulsifying there so no cross contamination with oil and water

2. My heaters only blow cold even when engine is hot

3. No excessive steam from exhaust

4. The engine runs normally not missfires no trouble starting, still smooth

5. No obvious leaks underneath the car

6. I lost my temperature dial for a while and it came back on last night with a bit of a jump, and acted like it was reading pressure quite erratic but has now settled.

7. The only thing is the temperature goes up and keeps going up will not come back down at all.

8. With the cap on the expansion tank off the level rises and falls continuely

so what do you think guys? what checks can I do to rule out other possibilties?
I am looking into pressure testing but if there is anything you guys can come up with so I can narrow it down a little before I start parting with money would be of great help

Thanks in advance guys

Last edited by PikeyV6; 11-08-08 at 12:32. Reason: missed #8
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: please help major overheat problems

I suspect you have the plastic impeller type water pump and this has just exploded, easy to check, remove the top hose from the radiator and start the car, if the water flows then it'll be OK, but if the water doesn't then it's cambelt change time too. If that's fine then go for for a compression test. The other option is a stuck closed thermostat, very rare but it has happened.

I suspect my first guess will be the problem though as your not geting flo through to the heater matrix and that depends on the water pump to push it round.
Smaky is offline  
Status: - Update
Posts: n/a
Re: please help major overheat problems

thanks will try that
Status: -
AO Member
Join Date: Jul 2007
Location: Bristol
Posts: 135

Member car:

Alfa 156 2.4 JTD

Re: please help major overheat problems

I would agree with that my pump had a couple of missing impellars. Check if your radiator gets hot or warm or stays cold. If the rads gets hot that quickly you probably have big problems if heaters are blowing cold! If warm suspect water pump. IF cold thermostat or pump. Wonder where the impellar bits end up
tri_land is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
Re: please help major overheat problems

I'd say waterpump too.

Probably not a good idea to run the engine at all until it is checked out.
David C is offline  
Status: - Update
Posts: n/a
Re: please help major overheat problems

Definately looks like the water pump,

I filled the engine directly after testing the thermostat, then filled expansion tank run the engine.

It worked for a while then all of a sudden the temperature gauge stopped reading and both fans cut in. Now tell me if I am wrong but because I filled the engine directly that let it cool the engine for a while, but because my pump isn't working the water boiled off leaving no water in the engine which is why my gauge dropped off leading to overheating

I also tried the above removing the hose and had no water movement

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

major , overheat , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome