156 creaking dashboard. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 01-05-02 Thread Starter
Status: -
AO Member
Damian M's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: West Yorkshire
Posts: 522
156 creaking dashboard.

My 156 has suffered this from new. Its intermittant, of course, but when it occurs it lasts a of couple days then dissappears for a while only to return some other day.

Its a spongy sounding creak that occurs when I bring the clutch up and engage drive. Its at the biting point and stops when the clutch is fully engaged. Its noticable when setting off from standstill but less so on the move.

I've been down in the footwell and its not the pedal itself that creaks, it sounds to be behind the dashboard.

I try to ignore it when it occurs but to be honest its always really ****ed me off!

Anyone had the same?
Damian M is offline  
Sponsored Links
Status: -
AO Member
Join Date: Mar 2002
Location: Manchester
Posts: 30
I know I'm a bit late on this one but I've got thte same with my V6, but the clutch is shot and I need a new one quickly, 89K on the clock and the owner before me must have rode the clutch and drove with his foot on it!!

PS When pulling away in 1st gear does it judder on the clutch??
Stripe is offline  
(Post Link) post #3 of 4 Old 18-06-02 Thread Starter
Status: -
AO Member
Damian M's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: West Yorkshire
Posts: 522
Thanks for the reply Stripe but I don't think the clutch is shot. The car has had this creak from new and I'm sure you'll understand when I say I can't bring myself to allow an Alfa dealer to remove the dashboard to investigate it!

For the moment the noise has gone, until the weather changes again I think!
Damian M is offline  
Status: -
AO Silver Member
jomor's Avatar
Join Date: Apr 2002
Location: Hellas
Posts: 5,237

Member car:

147 1.6lt

Hi Damian, i had same problem on my 147 since i got her, i know it ****es you off believe me!
Appearing for 1-2 days and going away for a while. Temperature reasons i suppose.

Read this topic

Dealer got the problem solved by sticking soft tape at the suface behind dash and below the front windshield.

If you trust your dealer (!) go for it.
I did.
jomor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , creaking , dashboard

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome