156 Questions.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
156 Questions..

Having just bought a 156 V6 , I wonder if some-one could shed some light on the following for me...

1. I have a noise which seems to be coming from the brakes. It comes and goes and sounds like the pads are running on the discs. After speaking to one dealer , I was informed that this was due to the type of compound used in the Brake pads and the fact that the pads will touch the discs sometimes because of the wheel camber changes when driving.He suggested that if it persisted for long periods , I use a "Brake Degreaser" to cure the problem. Is this normal and has anyone else had it ?

2.I think that I might have the wishbone bush problem reported on other user's pages whereby a squeaking comes from my left wishbone when driving over speed ramps etc. Has anyone else had this repaired and what is the average cost for this type of work ?

3.Are there any recommended oil types which I should stick to using in the Alfa..

Any info would be appreciated..
Sponsored Links
Status: -
AO Member
Join Date: Jan 2002
Location: Switzerland
Posts: 116

Member car:

75 3.0 QV

I had a funny squeeling nose from my left rear brake, as if the pads were constantly scraping on the disc. In the end, I discovered that the disc protector (the metallic plate behind the disc) had been slightly bent and was touching the disc... Maybe you have the same problem...
realdriver is offline  
Status: -
AO Member
Join Date: Oct 2001
Location: Ireland
Posts: 237
Hi there,

I reported the squeeking suspension over speed bumps.

Turned out the joints were knackered on the anti-roll bar. Apparantly a common problem with Fiat Mareas using a similar component. It also led to a knocking noise from front that sounded like shocks were gone.

Dealer completely replaced anti-roll bar and problem went away.
Kendr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome