Radio Reception 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-08-08 Thread Starter
Status: -
AO Member
Join Date: Jun 2006
Location: Westbury Wilts
Posts: 12
Radio Reception 156

I have had my 156 for 3 yrs and the radio reception i sgetting worse , especially Radio 2 , and I am missing out on Terry Wogan !

I suspect it is the airel , anybody else suffered the same.
AdrianGP1963 is offline  
Sponsored Links
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: Radio Reception 156

Hi and welcome to AO

moved to 156 lounge
classicgal93 is offline  
Status: -
AO Silver Member
danant's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: East Ayrshire
Posts: 1,061
Images: 25

Member car:

156 JTS

Re: Radio Reception 156

Don't know about that but I get a strange beeping noise through my radio when it is on MW and I brake hard.
danant is offline  
Status: -
AO Member
Fyrfad's Avatar
Join Date: May 2008
Location: Pau, France
Posts: 76
Images: 2

Member car:

156 1.9 JTD SW

Re: Radio Reception 156

Have a look on the antenna thread and the areal connection on the headunit and give them a quick clean over. Could be just a bit of smudge and thread interface corrosion blocking Terry
Fyrfad is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , radio , reception

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome