Clutch slip on cold damp mornings - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Clutch slip on cold damp mornings

Has anyone experienced a slight clutch slip when first starting the 147 selespeed on a cold damp day?

It only happens for the first 10 or so gear changes and it over rev's quite a bit in between gears.<font face="Andale Mono">Text
Sponsored Links
Status: Paternal
AO Silver Member
Simon_S's Avatar
Join Date: Oct 2001
Location: United Kingdom
County: Warwickshire
Posts: 1,322
Images: 5
Hi Steve,
Mine does exactly what you describe; the engine speed does not drop during the first few gear shifts so the clutch has to slip. In city mode, it shifts up at higher revs when cold too. I suspect it's for emissions reasons - keeping the throttle open keeps the air and fuel flow up so the catalyst gets up to temperature more quickly.
Simon S
Simon_S is offline  
Status: -
AO Member
Join Date: Dec 2001
Location: Peterborough, UK
Posts: 26

Member car:

BMW 120d SE


Yep, mine too. Makes you sound like you can't change gears properly to people as you drive past them!!

Edd is offline  
Status: - Update
Posts: n/a
Hey my verdict is that every car on a cold start has its idle a bit higher and on normal transmissions you regulate the clutch by yourself even you press in a cold start for a while the revs remain a bit higher for a while so what do you expect the selespeed to do? I find it normal and for emission reasons, well I am still waiting for my 147 selespeed to be delivered but I will be aware of that.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , cold , damp , mornings , slip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome