Squeeky when driving - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-07-08 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Posts: 11
Squeeky when driving

Hi Guys,

I have an issue with my 156 1.8TS Veloce. Wheni drive in a straight line there seems to be a loud squeeky noise coming from the front, when i turn it seems to disappear. When i break it goes but then my breaks star squeeling until i stop.

I have no idea what the cause is? Do you guys have any idea?
Iglesias is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Re: Squeeky when driving

Mine does the same but from the back. I haven't investigated but i think its the pads are worn right down and the backing plate is just touching the wear lip around the edge of the disk.
Its on my list of jobs to do!
Rockhopper is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

driving , squeeky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome