my first alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-07-08 Thread Starter
Status: Easter! Bring it on
AO Silver Member
rodz1300's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Vale of Glamorgan
Posts: 2,703

Member car:

147 GTA

my first alfa

Well i finally bought my first Alfa.
51 plate 147 2.0 TS Lusso in metalic black with tan leather 64K (looks great). Got it at a good price as FARSH up to 52k when 60K service was done but it has not had a cam belt change as yet!!!!! .I have it booked in on wednesday for belts, variator and service. ( hope it lasts that long ) The water pump seems to be working fine so not having it done at the same time (maybee i should?) .

Really pleased with the car in general except for the horrible rusty back box and the poor ride . Not sure if mine is typical but the suspension seems to be unsettled by even minor potholes,overbanding etc. giving the feeling af being both harsh and bouncy at the same time!!!!. my 2.5 tdi A4 Avant has the lowered and stiffened sport suspension and seems to ride much better on uneven roads.
That said the 147 is much more fun to drive and sounds great ( may get a new back box soon to improve the look and sound) any suggestions?

il send in some pics of my new baby once the sun comes out.
rodz1300 is offline  
Sponsored Links
Status: Autolusso fan! :0)
AO Member
superkarlos's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Essex
Posts: 116
Re: my first alfa

May as well get the waterpump done for piece of mind, think you would only need to add another £50 to the job.

Your ride sounds about right!

CSC backbox is nice - around £170 delivered
superkarlos is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome