Windscreen washers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Windscreen washers

This might sound a bit silly but has anyone else had a problem with the windscreen washers. When I'm driving at motorway speeds the washer jets barely reach the windscreen, it's as if the pump is not strong enough.
Sponsored Links
Status: -
AO Member
147owner's Avatar
Join Date: Oct 2001
Location: Australia
County: Australian Capital Territory
Posts: 567

Member car:

RS Clio 197

Yes, I have noticed this, cruising at 100kmh-110kmh (60-70mph). Seems ok at surburban speeds, though.
147owner is offline  
Status: - Update
Posts: n/a
I must say I have thought this to be a concern too. I know that on the side of the washer jets, there is a adjustment screw (flathead) which you can aim the trajectory of the jets.

I tried to aim them higher, which ofcourse works great at 110km/hr, but does a great job at washing the windscreen of the car behind me, at suburban speeds!

Suffice to say that the jets are now aimed as per factory specs!


Status: - Update
Posts: n/a
return the cars for inspection. The tubing can get creased as it goes around the engine bay and this is a common fault.
Status: - Update
Posts: n/a
Cheers for the info. I'll take the car round to my dealer for inspection.
Status: -
AO Member
btmaldon's Avatar
Join Date: May 2008
Location: United Kingdom
County: Essex
Posts: 198
Re: Windscreen washers

If these are the same as the 156, there are four tiny holes in each washer jet. Try pushing a pin into each one. Worked a treat on mine.
btmaldon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

washers , windscreen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome