Alfa 166 2.5 V6 starting problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Alfa 166 2.5 V6 starting problem

Help. Since my alfa 166 (just over one year old with 28,000 miles) has come back from having the steering recall work done it from time to time refuses to start. The engine turns over freely but makes no attempt to start. It has been crated off by the RAC to the garage a number of times now but they fail to find the problem and eventually return it as OK now!
Sponsored Links
Status: No more guiletta... Auctioned off
Founder of AO
alfaowner's Avatar
Join Date: Apr 2001
Location: United Kingdom
County: Essex
Posts: 8,044
Images: 83

Member car:

Maserati GTS

Hi do you still have this problem? If so please give us more detailed info of what happens and when,ie weather conditions..... etc...... engine hot or cold etc.
alfaowner is offline  
Status: - Update
Posts: n/a
Problem solved at last by very determined mechanic in Alfa Garage in Hayes Middex. It turned out to be a wire which had worn its insulation through rubbing on metalwork near the fuse box. I wonder if this will turn out to be another recall for Alfas with wiring problems yet again. [img]smilies/wink.gif[/img]

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

166 , alfa , problem , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome