147 selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-07-08 Thread Starter
Status: -
AO Member
alfa_baller's Avatar
Join Date: Jun 2008
Posts: 30
147 selespeed

My 147 is just over 71000 i have been reading about changing the cambelts at 72000 Miles

I have my alfa book stamped four times when i got the car i do not know when the cambelt was changed can i get it changed just over 72000 miles
or change it straight away.

Also is there away of you know the cambelt is on its way out
i have noticed every morning when taking off the i would my foot on the gas and and it feels no power is going through then a second later the car gets full gas im taking off lightly its been happening for the last few days.

i also have the check number plate error on start up funny becasue sometimes i dont get the message. But i have had someone say i have no Reverse lights on when reversing. but i have asked someone else they said it was ok only one bulb was not working.
alfa_baller is offline  
Sponsored Links
Status: Autolusso fan! :0)
AO Member
superkarlos's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Essex
Posts: 116
Re: 147 selespeed

Think you should get it in for a cambelt service asap.
superkarlos is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome