electrical gremlin on lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-07-08 Thread Starter
Status: -
Join Date: Feb 2007
Posts: 7
electrical gremlin on lights

Hi Guys And Girls
I've got an s reg 156 2.0ts and its developed a problem with the lights only the o/s headlamp dipped beam comes on when switched on then if you flash onto main beam it wont switch off if you switch the lights off the headlamp stays on til you disconnect ther battery i have checked the bulbs they seem to be fine i have also taken the two earth leads from both inner wings and cleaned them up but to no avail

Any ideas cause i've run out

alfox is offline  
Sponsored Links
(Post Link) post #2 of 2 Old 20-07-08 Thread Starter
Status: -
Join Date: Feb 2007
Posts: 7
Re: electrical gremlin on lights

got this sorted had to call an autoelectrician he sorted it in about 20 mins
alfox is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , gremlin , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome