oi thumper! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-07-08 Thread Starter
Status: -
AO Member
russ's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Lincolnshire
Posts: 101

Member car:

156 selespeed

oi thumper!

Hi all - hope you're well.
Lost gears on the sele this week - checked oil res near the wing and it was empty. After trawling through here all night seemed atf was the stuff to top up with. Hasn't solved the problem but now sele pump thumps audibly every 7 seconds.
Does this mean it needs bleeding and why can't this be done without examiner??
To come clean when I topped up six months ago I seem to remember putting dot 4 in it. So possibly a mix in there. Would the pump even work on dot 4?
Bit confused on this one.
Also (always an also) anyone know a good place to shop for sparkplugs?
Cheers all.

Some mornings it barely seems worthwhile gnawing through the ropes.
russ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome