Wipers on 156...Irritating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Wipers on 156...Irritating

The wipers on our 156 seem to park in the correct position, but the drivers side blade drives me nutty as it flops over the screen surround a bit on the extremity of its sweep. Its noisy and it spoils the wipe as the rest of the blade lifts a bit when it does it.

Has anyone had this problem and found a cure. I don't think i can set the arm any lower in the 'park' position, so its irritating me quite a bit.

Fitting shorter blades would work, but look silly.

Any ideas??

Sponsored Links
Status: - Update
Posts: n/a
Re: Wipers on 156...Irritating

Hi had the same problem with a 156 ended ip fitting a new wiper linkage as there was some wear on the drivers side of my linkage which was causing the drivers wiper to travel too far.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156irritating , wipers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome