Odd noice!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Odd noice!!

Hey, when I first start up my bella there is a odd noice coming from under the bonnet, sounds similar to the desel sound BUT its not the variator as mine is only the 105BHP version of the 1.6 Twinny!!

So im at a lost to what it could be.

Any ideas people??

Many thnx
Sponsored Links
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Odd noice!!

if it stops after a couple of seconds it is usually dry tappets. the oil drains to the sump when engine is switched off and then it takes a few secs for it to reach the tappets when engine is started. thats nothing to worry about. many people mistake it for a variator noise and later find the variator was fine, luckily you cant make that mistake.
jug is offline  
Status: - Update
Posts: n/a
Re: Odd noice!!

Thnx mate, much help

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

noice , odd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome