MIL Engine Light ON - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-06-08 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 25

Member car:

alfa 147

MIL Engine Light ON

My alfa 147 engine light goes on and off intermittently and sometimes when its on my revs are restriced to 3000rpm but then the next day the light will go off and all will be fine. Or the light remains on but the car operates as normal??

To test this i purchased a diagnostic machine from ebay which tells me the fault is the cam position sensor. This appears rather difficult to replace. Has anyone attempted it? Is it difficult? Will it cure this light coming on? Is the cam position sensor a common failing and will i need any special tools to relocate the cam etc...

thanks peeps
camel305 is offline  
Sponsored Links
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: MIL Engine Light ON

yeah the cam sensor is a swine to replace, get a copy of elearn (cheap on ebay or free to download if you search) and you'll see what you need to do and what tools you need.
jug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , mil

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome