Engine Management Nightmares - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-06-08 Thread Starter
Status: -
AO Member
Jsutton's Avatar
Join Date: May 2005
Location: Pembrokeshire
Posts: 265
Images: 1

Member car:

Alfa Romeo 147

Engine Management Nightmares


I keep having the "engine management" light illuminating on my dashboard. I have been to the nearest Alfa garage (Eric Ashmole in Swansea) several times — at least four — and they are just messing me around. They keep simply resetting the system and telling me to come back if it comes back on. However when I come back they tell me the same thing again.

I won't be going up there again. There apparent incompetence is costing me a lot of time and money (I have to travel a long way to reach them).

This engine management light turns on, and will often turn itself back off again. I have already replaced two lambda probes and that didn't seem to work. The only other possibility they gave me was the air flow filter.

I think I’ve asked this question before but I really want to get to the bottom of this. Has anyone had a similar problem with the engine management light — with it turning on and off randomly? If so how did you repair it?


Jsutton is offline  
Sponsored Links
Status: enjoying ma julie
AO Silver Member
belfast bob's Avatar
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
Re: Engine Management Nightmares

best thing to do is find a proper ALFA indy, or a member on here who has a code reader and go visit to get the codes read properly.

in the mean time check your air intake pipes are properly sealed up, no holes or lose hosing .

if it is driving 100% it could be nothing at all,but if it keeps coming on then best to get checked
belfast bob is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: Engine Management Nightmares

Did they not READ the codes before they reset them? That would have told them what it was.


I had a look back on you other posts and the only one you quote is Z50 ... all error codes start with a P, so they are really leading you up the garden path ...

What year and engine size is the 147? If it's post 2001, any good autoelectrician or garage probably has a diagnostic system that can read it as it will be EODB ... unless it's a diesel, then you're in the hands of Alfa unless it's post-2004 ....

cheers, Gary

HIS: 1998 156 2.0 TSpark with Sport Pack 2, sunroof and hi-level spoiler in Alfa Rosso. V6 intake mod, clear side repeaters and Zeatek undertray.

HERS: 2009 MiTo 1.4 95bhp Turismo arrived 21st November in Techno Grey with colour-coded headlight surrounds.

"If you're driving on the edge ... you're leaving too much room!"
My Alfa156 Web Site - how-to's, piccies, links, useful stuff, etc.
gazza82 is offline  
Status: -
AO Member
Join Date: Jun 2008
Location: australia
Posts: 10
Re: Engine Management Nightmares

hi, im yichen,, i work in australia, u need to get back to the shop and ask them to print the errors report from the examiner to know exactly whats going on in u car, the most comun problem its oxy sensors, but u said its been done, what kind of 147 its u car? TS? sellespeed? manual? i am mechanic wotking with alfa.
yichen is offline  
Status: -
AO Member
Join Date: Feb 2008
Location: Northumberland
Posts: 237

Member car:

156 SW 1.8 Lusso

Re: Engine Management Nightmares

I had a similar problem with my 156. I bought myself a code reader for about £30 off ebay. I read the codes and reset them. So far the light hasn't come back on! I don't quite know why, but I don't really mind.
neileg is offline  
Status: -
AO Member
charlie8's Avatar
Join Date: Jun 2005
Posts: 106

Member car:

GT JTS 2.0

Re: Engine Management Nightmares

Looking back does your light only come on ~ 5 miles into the journey from cold ?

charlie8 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , management , nightmares

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome