Electrical Gremlins - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Electrical Gremlins

Ok, I have a 147 2.0 on a 53 plate. Lusso trim so its heated seats, climate control etc. I bought it back in january, no problems, last month I started getting fairly random VDC and ABS errors which were gradually getting worse so I changed the battery (original one was still in). Now I'm getting a far worse problem, if I try to start the car with any electrical items on (radio, air con, lights) it won't start and if I select reverse with anything on it kills the electrics and stalls the engine.

I'm going to have a look tomorrow when the weather drys up to make sure nothing has come loose since I changed the battery and that the earth connections are in good nick. The local motorfactor sorted me out with a heavy duty battery when I got it, 600amp cold crank so that shouldnt really be the problem. Any ideas or suggestions about what else it could be?
Sponsored Links
Status: - Update
Posts: n/a
Re: Electrical Gremlins

Right, went out this morning in a brief dry period. Checked the battery was tight and tidy, had a check of the fuses too, one seemed a little loose so I popped it in fully. Loaded up the electrics and started her with no problems. Hopefully that was it, should know when I hit a hot\freezing day and the air con is draining more.
Status: -
AO Member
skint147's Avatar
Join Date: Jul 2008
Location: Reading
Posts: 10
Re: Electrical Gremlins

I've had almost identical problems, and it's been getting unstartable recently.

The AA gave it a good look. Tried a new battery, but it made no difference.

Put it into reverse, or press the brake pedal, and all the electrics die for a few seconds - killing the engine unsurpringly.

Removing the fuses for the brake & reversing lights and I managed to get it round the block.

Perhaps I should drive straight to an auto-electrician, but not far without brake lights.

Are you still having the problem?
skint147 is offline  
Status: -
AO Silver Member
corbo's Avatar
Join Date: May 2008
Location: United Kingdom
County: Somerset
Posts: 1,610
Re: Electrical Gremlins

Has the replacement battery cleared up your original VDC/ABS problems?

corbo is offline  
Status: - Update
Posts: n/a
Re: Electrical Gremlins

Mine has only cropped up once and its not as severe at the moment. All I got was a message telling me all my sidelights had failed when they clearly had not last week. Nothing since, especially the electrics dying on braking or selecting reverse. I suspect a loose connection somewhere or dampness getting into something.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , gremlins

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome