Hello (airbag trouble) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 13-06-08 Thread Starter
Status: -
Join Date: Jun 2008
Posts: 5
Help Hello (airbag trouble)

Hello ive brought my first alfa 156 twin spark last week what a car.
The airbag light stays on all the time dose anyone what this means i know it's going cost me just like to know a ball park figure if any one knows. should i turn the airbag off with the key ???????? many thanks
cjp49 is offline  
Sponsored Links
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: Hello (airbag trouble)

Hi and welcome to AO

Moved to 156 lounge
classicgal93 is offline  
Status: -
Join Date: Jun 2008
Posts: 7

Member car:

156 selespeed

Re: Hello (airbag trouble)

It means that there is a failiure in your airbag system
It could be that the airbag ECU is broken or that the electric plug
under 1 of the seats has a bad connection
It often happens when you jumpstart the car that the airbag ECU will be damaged
Sometimes the alfa garage can reset the error with an examiner
The lock for the airbag is only to turn of the passengers airbag,and it has nothing to do with
the red airbag sign in your display

PS sorry for my poor english i am dutch

Last edited by mayday1000; 13-06-08 at 23:29.
mayday1000 is offline  
Status: Vroooooooom!
AO Silver Member
paulmacs's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Armagh
Posts: 2,338
Images: 4

Member car:

Giulietta QV

Re: Hello (airbag trouble)

most likely a loose connection and as such, check all connections under the seats and get light reset at a local dealer or indie, or with any home diag software capable of accesing the airbag ecu (ALFADIAG).

cost wise around 40 quid if you take it in for a reset.
paulmacs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

airbag , trouble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome