Wheel vibration under acceleration - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-06-08 Thread Starter
Status: -
Join Date: Apr 2008
Posts: 7

Member car:

Alfa Sportwagon

Wheel vibration under acceleration

Having replaced two front tyres and had the balance and allignment redone there was still vibration over 75 mph. Took the car back and balancing was re-checked and given the OK. The vibration is still there but it is much worse when accelerating and a little under braking. I bought my Sportwagon 1.8 2 months ago and was told that the discs had been change...bills to prove it and they are hardly worn so appears true! I have heard rthat this could be down to drive shafts...any suggestions?
nic waller is offline  
Sponsored Links
Status: enjoying ma julie
AO Silver Member
belfast bob's Avatar
Join Date: Dec 2007
Location: United Kingdom
County: Antrim
Posts: 2,890
Re: Wheel vibration under acceleration

would have thought drive shaft would be the next place to look - get her to a trusted indy
belfast bob is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

acceleration , vibration , wheel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome