Injection failure light on and loss of power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-06-08 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 9
Injection failure light on and loss of power

As the title says, my injection failure warning light has come on (the orange, engine-shaped one) and at the same time my 156 2.5 V6 has lost power. It goes ok but there is a big difference in acceleration now.

Any ideas as to the cause of the problem and how I could solve it?

wadster is offline  
Sponsored Links
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Injection failure light on and loss of power

there are thousands of possible causes, you need a diagnostic to determine what it is in this case.
jug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , injection , light , loss , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome