Knocking - engine mounts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-06-08 Thread Starter
Status: -
AO Member
Join Date: May 2008
Location: Long Preston
Posts: 137
Knocking - engine mounts

HELP! Have decided that suspension knock from my newly aquired 2002 2.4 Jtd is actually the driveshaft inner joints contacting the bottom arm inner mountings, I can see were its been touching
Have tried adjusting position of top tie bar and that just made it worse so let it find its own position, anybody got any ideas why the engine is "hanging too low" - so to speak or are mountings prone to wear?
Also whats the easy way to get n/s side light buld holder out as mine is stuck and little pull tag broken off or is it a headlight out job now?
longprest is offline  
Sponsored Links
Status: -
Club Member
Membro Medio
ALFAPAT's Avatar
Club Member Number: 237
Join Date: Nov 2001
Location: United Kingdom
County: Moray
Posts: 1,862
Images: 6
Re: Knocking - engine mounts

Have you checked that the engine mounts are tight up to the chassis legs and bolted securely to the engine.
Also check the rear mount underneath the car to see if its tight up to the underside mount before you think of wear. I am replacing mounts just now because they are weak and causing judder on clutch engagement so they are being condemmed but for a different reason, this is also 2.4jtd. So hope that helps.
ALFAPAT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , knocking , mounts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome