Hello and crank shaft sensor! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-06-08 Thread Starter
Status: -
Join Date: Sep 2004
Location: Newcastle
Posts: 6

Member car:

147 1.6 TS LUSSO

Hello and crank shaft sensor!

Hello there..
I drive a 147 1.6ts on a 2001 plate..
Been registered with alfaowner for ages now and used the forum numerous time and found it very helpful..

First post and first major problem.

Had my car diagnosed today with a faulty crankshaft sensor. Car would run for 10 to 15 minutes then engine would cut out (no rattles or anything) and the car would grind to a halt.. giving the engine management light. Leaving the car for 20 mins or so would allow it to start back up again.. but not for long.

Being charged 175 (including clearing a couple of other faults out the ECU..)
Does this sound reasonable?
jackblack is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello and crank shaft sensor!


moved to 147 lounge
classicgal93 is offline  
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,561
Images: 13
Re: Hello and crank shaft sensor!

175 sounds a bit expensive. The sensor costs around 20 plus VAT to buy and fitting should take between 1/2 and 3/4 hour for someone who knows what they are doing.

Clearing the fault codes shouldn't cost too much, I haven't had it done but I would guess at 20 or so.
symon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crank , sensor , shaft

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome