156 2.5 v6 problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-06-08 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 56

Member car:

156 2.5 V6

156 2.5 v6 problems

hi everyone,if your car has been getting that red injector light appearing on the rev counter an dont no how to fix try this i did an ever since it has not come back.
when it comes on do the reset procdure an once it has gone out lift the bonnet and check were the injector relays and fuel relays, they are attacted to a plate in front of the battery, on my car it was really loose so i made sure all the relays were in properly an tighten the plate the relays are attacted to. the red light only appeared when going over bumps. since i have done all this i have had no problems
ricardo 83 is offline  
Sponsored Links
Status: -
AO Member
Burnsy's Avatar
Join Date: Dec 2004
Location: Bath, UK
Posts: 220
Re: 156 2.5 v6 problems

thanks for the tip Ricardo, will be another thing to check if I get any probs. Fingers crossed.
Burnsy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome